Okunma

Apple 64 Bit Kod İstiyor!


21 Ekim 2014 Salı 10:00
Apple 64 Bit Kod İstiyor!

İlk olarak geçtiğimiz yıl sonunda tanıttığı akıllı telefonu iPhone 5S ile 64 bit mobil işlemci akımını başlatan Apple, geliştiricilerin uygulamalarını 64 bit kodlar ile güncellemeleri süre verdi. Şirketten yapılan açıklamaya göre 1 Şubat 2015’ten sonra 64 bit kod içermeyen yeni uygulamalar ve uygulama güncelleştirmeleri AppStore’a kabul edilmeyecek.

Apple, 64 bit kod bulundurmayan uygulamaları AppStore’dan kaldırmayacak ancak 1 Şubat sonrasında yayınlanmak istenen her uygulama ya da güncelleştirme 64 bit kod içermek zorunda olacak. Burada geliştiricilerin yapması gereken şey ise uygulamalarını Xcode’un son sürümü ve “Standart Mimariler” ayarı ile geliştirmek.

14-10/21/64bit.jpg

Performans artacak

Uygulamaların 64 bit kodlar içermesi A7 ve A8 işlemcilerini kullanan Apple cihazlarında (iPhone 5S, iPhone 6, iPad Air gibi) önemli performans artışı yaratacak. Özellikle oyunlarda net bir şekilde görülebilecek olan bu performans artışı, kullanıcıların işine yarayacak gibi gözüküyor.

:: 64 bit mobil işlemciler hakkında ne düşünüyorsunuz?




yazarAtakan Sayın

Mobil teknoloji tutkunu olan Atakan, yıllardır Android kullanıyor. PC mi Mac mi sorusuna ise kesinlikle Mac cevabını veriyor.
Yazarın diğer haberlerine ulaşmak için tıklayın.

Yeni ! ShiftDelete.Net ya da SDN Forum hesabınız ile yorum yaparak yorumlarınızın rumuzunuz ile yayınlanmasını sağlayabilirsiniz. Giriş için tıklayın.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak.

15 yorum - “Apple 64 Bit Kod İstiyor!”

  1. SDN Okuru dedi ki:

    Apple’ın işi çok basit App Store’a bir politika verdi miydi tamamdır zaten yeni modeller de 64 bit olunca hepsi 64 bit olur tamamen. Yani iOS 10 zamanları falan.

  2. SDN Okuru dedi ki:

    iphone 5 uygulama desteklemeyecek kısmı tam bir hurafe. uygulamaları build ederken sadece 64 bit değil hem 32 hem 64 bit de build ederek göndermeniz gerekmektedir yazıyo resimdeki yazıda. “build a single binary with both 32 bit and 64 bit code”

  3. SDN Okuru dedi ki:

    adamlar 64 bit yazdığında mutlaka 32 bit de desteklemeli yoksa ipad mini, ipad 4, iphone 5, iphone 5c ve alt sürümleri çöp olur. düşünsenize facebook uygulama güncellemesini alamıyorsunuz. apple 32 bitlik işlemciler için bir şekilde uygulamayı uyumluluk modundaki gibi çalıştırmalı. aynı zamanda satışı devam eden iphone 5c yi satması çok saçma oalcaktır.

  4. SDN Okuru dedi ki:

    Adamlar hep seviyeyi bir üst levele çekmek için uğraşıyorlar. Uyamayanlar kalsın önemli değil…

  5. SDN Okuru dedi ki:

    Apple candır. Gerisi laff

  6. SDN Okuru dedi ki:

    apple candır gerisi heyecandır 😀

  7. SDN Okuru dedi ki:

    peki 2015 ten sonraki app güncellemelerinde benim iphone 5 im çok mu kasacak

  8. SDN Okuru dedi ki:

    İphone 5c üvey evlat

  9. SDN Okuru dedi ki:

    İşte bu apple ın gücü app storeda olmak istiyorsanız bunu yapacaksınız 🙂 bakalım google android lolipop ile 64 bit daha iyi olucak dedi bunu uygulama geliştiricilere telefon üreticisi şirketlerine nezaman ve nasıl yansıtacak çok merak ediyorum iphone 6 kullanıyorum oyun performansı zaten süperdi 8.1 le dahada güzel bir hal aldı telefon ama 64bit uygulamların zorunlu olması çok süper olucak

  10. SDN Okuru dedi ki:

    1 şubat 2015 itibariyle Iphone’un çuvallamaya başladığı günlerin geleceğini söyleyebiliriz. Çünkü 64 bit uygulamalar daha fazla RAM isteyecek ve iphone ‘un 1 GB RAM’i bunlara yetmeyecek. Apple’ın baştan beri stratejisi buydu zaten. RAM’da sıkıntı yasayan kullanıcıları, psikolojik olarak gelecek yıl 2 GB RAM’lı iphone 6s’yi almaya zorlamak.

" Apple 64 Bit Kod İstiyor! konulu haberimizde ShiftDelete.Net olarak sizlere Apple 64 Bit Kod İstiyor! ile ilgili son gelişmeleri aktarmak istedik. Hemen yukarıda Apple 64 Bit Kod İstiyor! ile ilgili yorum ve görüşleri inceleyerek sizlerde yorum bırakabilirsiniz. "